GCCG on Ubuntu 16.04 LTS

For discussion the Generic Collectible Card Game engine designed and run by Tommi "wigy" Ronkainen

Moderators: Vastor Peredhil, Thorsten the Traveller, GCCG

GCCG on Ubuntu 16.04 LTS

Postby iGogol » Fri Mar 24, 2017 3:18 pm

... or how to become bald in such a short time ! :twisted:

Hi everybody !

In a late post about GCCG and Debian Jessie (8.6), I managed to install GCCG.
i do the same things with Ubuntu 16.04 LTS, but i can't run GCCG ... :(

Code: Select all
sudo apt-get install libsdl1.2debian libsdl-image1.2 libsdl-mixer1.2 libsdl-net1.2 libsdl-sound1.2 libsdl-ttf2.0-0
sudo apt-get install libsdl1.2debian:i386
mkdir gccg
cd gccg
mkdir core
svn checkout http://svn.code.sf.net/p/gccg/svn/core/ /home/*username*/gccg/core
mkdir metw
svn checkout http://svn.councilofelrond.org/svn/metw/ /home/*username*/gccg/metw

*username* is the name of the personnal repertory (mine is ... ;))
I copy my ".gccg" folder in my "Home".

I have the error message :
You must install package containing program binaries, for example 'linux-i386'.

But i can't found the package "linux-i386" ...

If someone can help me, I would be grateful.
User avatar
iGogol
 
Posts: 67
Joined: Tue Nov 29, 2011 9:15 am
Location: Montaigu, France

Re: GCCG on Ubuntu 16.04 LTS

Postby iGogol » Sat Mar 25, 2017 7:03 am

Hi everybody. I found a topic about the installation of GCCG on Ubuntu 11.10 : http://www.councilofelrond.org/forum/viewtopic.php?f=20&t=1827

I do the same things as zirilan. And i have the same error message :

Code: Select all
mkdir gccg
cd gccg
mkdir core
svn checkout http://svn.code.sf.net/p/gccg/svn/core/ /home/*username*/gccg/core
mkdir metw
svn checkout http://svn.councilofelrond.org/svn/metw/ /home/*username*/gccg/metw
cd core
make all
./Metw


I have this message :
Code: Select all
You must install package containing program binaries, for example 'linux-i386'.


I read in this precedent topic that i must install some development packages of SDL libraries :
    libsdl-image1.2-dev
    libsdl-mixer1.2-dev
    libsdl-net1.2-dev
    libsdl-sound1.2-dev
    libsdl-ttf2.0-dev
Same problem.

And i install other versions of SDL libraries :
    libsdl2-2.0-0
    libsdl-image-2-2.0-0
    libsdl-mixer-2-2.0-0
    libsdl-net-2-2.0-0
    libsdl-ttf-2-2.0-0
Same problem

When i do the comman "make all" in the repertory "core", i have this message :
Code: Select all
g++ -o ccg_text_client tmp/client.o tmp/parser_libcards.o tmp/parser_libnet.o tmp/parser.o tmp/data_filedb.o tmp/parser_lib.o tmp/tools.o tmp/carddata.o tmp/xml_parser.o tmp/security.o tmp/data.o tmp/localization.o  tmp/driver.o tmp/game.o tmp/interpreter.o tmp/SDL_rotozoom.o tmp/text-driver.o tmp/game-text-version.o `sdl-config --libs` -lSDL_net -lSDL_mixer
/usr/bin/ld: tmp/text-driver.o: référence au symbole non défini «pthread_cancel@@GLIBC_2.2.5»
//lib/x86_64-linux-gnu/libpthread.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Makefile:88 : la recette pour la cible « ccg_text_client » a échouée
make: *** [ccg_text_client] Erreur 1


:evil: I doesn't understand that ! :(

Edit : another topic : http://www.councilofelrond.org/forum/viewtopic.php?f=20&t=2122
User avatar
iGogol
 
Posts: 67
Joined: Tue Nov 29, 2011 9:15 am
Location: Montaigu, France


Return to GCCG

Who is online

Users browsing this forum: No registered users and 1 guest